注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

长风明志的博客

不要也不能做下一个谁,应该且可以做第一个自己

 
 
 

日志

 
 

静态NAT配置  

2011-06-05 22:55:36|  分类: 计算机网络 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

 

A、静态NAT配置拓扑结构图(图2)

静态NAT配置 - changfengmingzhi - 长风明志的博客

  

(一)、静态NAT配置步骤(取用图2拓扑结构图)

A、实验目的

1、配置静态内部源地址转换NAT。

2、查看NAT相关信息。

3、监测IP的转换。

4、测试内网和外网间的双向连通性。

 

B、实验设备

1、Cisco2600XM系列路由器三台。

2、交叉线序网线一条。

3、带网卡及装有超级终端的计算机一台。

4、控制台专用线一根。

5、DCE、DTE线缆各一条

 

C、实验网络拓扑图

     取用图3拓扑结构图

 

D、实验配置过程及结果监测

(1)、配置路由器RA的各个端口IP,并配置静态NAT映射关系

Router>en

Router#conf t

Router(config)#hostn RA

RA(config)#int fa0/0

RA(config-if)#ip addr 172.16.1.1 255.255.255.0  //:在fa0/0端口上配置内部本地地址172.16.1.1;

RA(config-if)#ip nat inside              //:指定fa0/0端口为连接网络的内部端口;

RA(config-if)#no shut

RA(config-if)#int s0/0

RA(config-if)#ip address 200.1.1.1 255.255.255.0  //:在S0/0端口内部全局地址;

RA(config-if)#clock rate 64000        (这个设置时钟速率的命令好像应该在RA而不是RB中设置)

RA(config-if)#ip nat outside              //:指定S0/0端为连接外部网络的外部端口;

RA(config-if)#no shut

RA(config-if)#exit

RA(config)#ip nat inside source static 172.16.1.3 200.1.1.5 

//:建立IP地址之间的静态映射,172.16.1.3为内部本地地址 200.1.1.5内部全局地址;

RA(config)#ip route 0.0.0.0 0.0.0.0 200.1.1.2  //:配置默认静态路由;

RA(config)#end

RA#

 

(2)、配置路由器RB的S0端口以及Loopback端口的IP地址

Router>en

Router#conf t

Router(config)#hostn RB

RB(config)#int loopback0   //:配置回送接口loopback0,用于模拟外网IP地址;

RB(config-if)#ip addr 202.1.1.2 255.255.255.0

RB(config-if)#no shut

RB(config-if)#int s0/0

RB(config-if)#ip address 200.1.1.2 255.255.255.0

RB(config-if)#no shut

RB(config)#line vty 0 4           //:配置终端登录密码;

RB(config-line)#password cisco

RB(config-line)#enable password cisco2    //:配置使能密码,即是登录特权模式密码;

RB(config-if)#end

RB#

 

(3)、配置路由器RC的fa0/0端口的IP地址

Router>en

Router#conf t

Router(config)#hostn RC

RC(config)#int fa0/0

RC(config-if)#ip addr 172.16.1.3 255.255.255.0

RC(config-if)#no shut

RC(config-if)#exit

RC(config)#ip default-gateway 172.16.1.1

//:配置RC的缺省网关,指RA的fa0/0接口的IP地址;

RC(config)# no ip routing       //:关闭RC的路由功能,让RC只作内部网主机来使用;

RC(config)#line vty 0 4               //:配置终端登录密码;

RC(config-line)#password cisco

RC(config-line)#enable password cisco2    //:配置使能密码,即是登录特权模式密码;

RC(config-if)#end

RC#

 

(4)、查看和监测静态内部地址转换信息

RC#ping

Protocol [ip]:               //:使用默认TCP/IP协议

Target IP address: 202.1.1.2    //:目标地址为202.1.1.2;

Repeat count [5]: 200      //:发送IP包(即是ICMP Echos包)数量为200,缺省为5;

Datagram size [100]:            //:IP包的缺省值为100比特;

Timeout in seconds [2]:           //:设定逸出时间,缺省为2秒;

Extended commands [n]:         //:是否扩充命令,缺省为N;

Sweep range of sizes [n]:

Type escape sequence to abort.     //:按ESC键退出;

Sending 200, 100-byte ICMP Echos to 202.1.1.2, timeout is 2 seconds:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Success rate is 100 percent (200/200), round-trip min/avg/max = 20/23/28 ms

RC#

 

RA#sh ip nat stat      //:show ip nat statistics 列出RA的NAT统计信息;

Total active translations: 1 (1 static, 0 dynamic; 0 extended)

//:当前NAT活动转换数为1,其中表态转换数为1,动态转换数为0,其它转换数为0;

Outside interfaces:        //:连接外部网络的外部端口 Serial0/0;

  Serial0/0

Inside interfaces:          //:连接内部网络的内部端口  FastEthernet0/0;

  FastEthernet0/0

Hits: 425  Misses: 0     //:进行了425次NAT转换,丢失转换(不成功的转换)为0;

Expired translations: 0

Dynamic mappings:

RA#

RA#sh ip nat tran   //:show ip nat translations查看当前进行的NAT转换

Pro Inside global      Inside local       Outside local      Outside global

--- 200.1.1.5          172.16.1.3         ---                ---

RA#

 

(5)、测试双向连通性

RC#

RC#telnet 202.1.1.2       //:远程登录202.1.1.2(即是RB上回送接口上模拟的外部主机)

Trying 202.1.1.2 ... Open   //:登录成功,即是内网到外网已经成功连通;

User Access Verification

Password:              //:输入密码(CISCO);

RB>en

Password:            //:输入密码(CISCO2)进入RB的特权模式;

RB#telnet 200.1.1.5   

//:远程登录200.1.1.5(即是RC,此地址已表态映射到172.16.1.3地址上)

Trying 200.1.1.5 ... Open   //:登录成功,即是外网到内网已经成功连通;

User Access Verification

Password:              //:输入密码(CISCO);

RC>en

Password:            //:输入密码(CISCO2)进入RC的特权模式;

RC#

 

RB#ping 172.16.1.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.3, timeout is 2 seconds:

..... 

Success rate is 0 percent (0/5)

//:外网访问内网中已建立表态映射的主机,必须使用映射后的IP地址;外网没有到内网的路由;

RB#ping 200.1.1.5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 200.1.1.5, timeout is 2 seconds:

!!!!!   //:外网能够访问内网主机映射后的IP地址;

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

RB#

  评论这张
 
阅读(2457)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018